BSD Kernel Interfaces Manual
ehci — USB Enhanced Host Controller driver
The ehci driver provides support for the USB Enhanced Host Controller Interface, which is used by USB
EHCI controllers are peculiar in that they can only handle the USB 2.0 protocol. This means that they nor-
mally have one or more companion controllers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Con-
sequently each USB connector is electrically connected to two USB controllers. The handling of this is
totally automatic, but can be noticed since USB 1.x and USB 2.0 devices plugged in to the same connector
appear to connect to different USB busses.
ohci(4), uhci(4), usb(4)
The ehci device driver first appeared in FreeBSD 5.1.
The driver is not finished and is quite buggy.
There is currently no support for isochronous transfers.
March 20, 2005