BSD Kernel Interfaces Manual
aue — ADMtek AN986 Pegasus USB Ethernet driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The aue driver provides support for USB Ethernet adapters based on the ADMtek AN986 Pegasus chipset.
The LinkSys USB10T adapters that contain the AN986 Pegasus chipset will operate at 100Base-TX and full-
The Pegasus contains a 10/100 Ethernet MAC with MII interface and is designed to work with both Ethernet
and HomePNA transceivers. Although designed to interface with 100Mbps peripherals, the existing USB
standard specifies a maximum transfer speed of 12Mbps. Users should therefore not expect to actually
achieve 100Mbps speeds with these devices.
The Pegasus supports a 64-bit multicast hash table, single perfect filter entry for the station address and pro-
miscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints.
The aue driver supports the following media types:
Enable autoselection of the media type and options. The user can manually
override the autoselected mode by adding media options to the
Set 10Mbps operation. The mediaopt option can also be used to enable
full-duplex operation. Not
specifying full duplex
Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be
used to enable full-duplex operation. Not specifying full duplex
implies half-duplex mode.
The aue driver supports the following media options:
Force full duplex operation. The interface will operate in half duplex mode if
this media option is not specified.
For more information on configuring this device, see ifconfig(8).
Adapters supported by the aue driver include:
• Abocom UFE1000, DSB650TX_NA