BSD Kernel Interfaces Manual
ahci — Serial ATA Advanced Host Controller Interface driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The following tunables are settable from the loader:
controls Message Signaled Interrupts (MSI) usage by the specified controller
single MSI vector used, if supported (default);
multiple MSI vectors used, if supported;
controls Command Completion Coalescing (CCC) usage by the specified controller. Non-zero value enables
CCC and defines maximum time (in ms), request can wait for interrupt, if there are some more requests
present on controller queue. CCC reduces number of context switches on systems with many parallel
requests, but it can decrease disk performance on some workloads due to additional command latency.
controls SATA interface Power Management for specified channel, allowing some power to be saved at the
cost of additional command latency. Possible values:
interface Power Management is disabled (default);
device is allowed to initiate PM state change, host is passive;
host initiates PARTIAL PM state transition every time port becomes idle;
host initiates SLUMBER PM state transition every time port becomes idle.
driver initiates PARTIAL PM state transition 1ms after port becomes idle;
driver initiates SLUMBER PM state transition 125ms after port becomes idle.
Some controllers, such as ICH8, do not implement modes 2 and 3 with NCQ used. Because of artificial
entering latency, performance degradation in modes 4 and 5 is much smaller then in modes 2 and 3.
Note that interface Power Management is not compatible with device presence detection. You will have to
reset bus manually on device hot-plug.
setting to nonzero value limits