BSD Kernel Interfaces Manual
em — Intel(R) PRO/1000 Gigabit Ethernet adapter driver
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The em driver provides support for PCI Gigabit Ethernet adapters based on the Intel 82540, 82541ER,
82541PI, 82542, 82543, 82544, 82545, 82546, 82546EB, 82546GB, 82547, 82571, 81572, 82573, and 82574
Ethernet controller chips. The driver supports Transmit/Receive checksum offload and Jumbo Frames on all
but 82542-based adapters. Furthermore it supports TCP segmentation offload (TSO) on all adapters but
those based on the 82543, 82544 and 82547 controller chips. For further hardware information, see the
README included with the driver.
For questions related to hardware requirements, refer to the documentation supplied with your Intel
PRO/1000 adapter. All hardware requirements listed apply to use with FreeBSD.
Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500
bytes with the ifconfig(8) utility configures the adapter to receive and transmit Jumbo Frames. The max-
imum MTU size for Jumbo Frames is 16114.
This driver version supports VLANs. The em driver supports the following media types:
autoselect Enables auto-negotiation for speed and duplex.
10baseT/UTP Sets 10Mbps operation. Use the mediaopt option to select full-duplex mode.
Sets 100Mbps operation. Use the mediaopt option to select full-duplex mode.
1000baseSX Sets 1000Mbps operation. Only full-duplex mode is supported at this speed.
1000baseTX Sets 1000Mbps operation. Only full-duplex mode is supported at this speed.
The em driver supports the following media options:
full-duplex Forces full-duplex operation
half-duplex Forces half-duplex operation.
Only use mediaopt to set the driver to full-duplex. If mediaopt is not specified, the driver defaults