BSD Kernel Interfaces Manual
bge — Broadcom BCM570x/5714/5721/5722/5750/5751/5752/5789 PCI Gigabit Ethernet adapter driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The bge driver provides support for various NICs based on the Broadcom BCM570x, 5714, 5721, 5722,
5750, 5751, 5752 and 5789 families of Gigabit Ethernet controller chips.
All of these NICs are capable of 10, 100 and 1000Mbps speeds over CAT5 copper cable, except for the
SysKonnect SK-9D41 which supports only 1000Mbps over multimode fiber. The BCM570x builds upon the
technology of the Alteon Tigon II. It has two R4000 CPU cores and is PCI v2.2 and PCI-X v1.0 compliant.
It supports IP, TCP and UDP checksum offload for both receive and transmit, multiple RX and TX DMA
rings for QoS applications, rules-based receive filtering, and VLAN tag stripping/insertion as well as a
256-bit multicast hash filter. Additional features may be provided via value-add firmware updates. The
BCM570x supports TBI (ten bit interface) and GMII transceivers, which means it can be used with either
copper or 1000baseX fiber applications. Note however the device only supports a single speed in TBI mode.
Most BCM5700-based cards also use the Broadcom BCM5401 or BCM5411 10/100/1000 copper gigabit
transceivers, which support autonegotiation of 10, 100 and 1000Mbps modes in full or half duplex.
The BCM5700, BCM5701, BCM5702, BCM5703 and BCM5704 also support jumbo frames, which can be
configured via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8)
utility configures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve
performance for certain tasks, such as file transfers and data streaming.
The bge driver supports the following media types:
autoselect Enable autoselect