BSD Kernel Interfaces Manual
alc — Atheros AR8131/AR8132 Gigabit/Fast Ethernet driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The alc device driver provides support for Atheros AR8131 PCI Express Gigabit Ethernet controllers and
Atheros AR8132 PCI Express Fast Ethernet controllers.
All LOMs supported by the alc driver hav e TCP/UDP/IP checksum offload for transmit, TCP segmentation
offload (TSO), hardware VLAN tag stripping/insertion features, Wake On Lan (WOL) and an interrupt mod-
eration mechanism as well as a 64-bit multicast hash filter.
The AR8131/AR8132 supports Jumbo Frames (up to 9216 bytes), which can be configured via the interface
MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the
adapter to receive and transmit Jumbo Frames.
The alc driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user can manually override the
autoselected mode by adding media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation.
Set 100Mbps (Fast Ethernet) operation.
1000baseTX Set 1000baseTX operation over twisted pair.
The alc driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The alc device driver provides support for the following Ethernet controllers:
• Atheros AR8131 PCI Express Gigabit Ethernet controller
• Atheros AR8132 PCI Express Fast Ethernet controller
Tunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
This tunable disables MSI support on the Ethernet hardware. The default value is 0.
This tunable disables