BSD Kernel Interfaces Manual
ath — Atheros IEEE 802.11 wireless network driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The ath driver provides support for wireless network adapters based on the Atheros AR5210, AR5211,
AR5212, and AR5416 programming APIs. These APIs are used by a wide variety of chips; most all chips
with a PCI and/or CardBus interface are supported.
Supported features include 802.11 and 802.3 frames, power management, BSS, IBSS, MBSS, TDMA, and
host-based access point operation modes. All host/device interaction is via DMA.
The ath driver encapsulates all IP and ARP traffic as 802.11 frames, however it can receive either 802.11 or
802.3 frames. Transmit speed and operating mode is selectable and depends on the specific chipset.
AR5210-based devices support 802.11a operation with transmit speeds of 6 Mbps, 9 Mbps, 12 Mbps, 18
Mbps, 24 Mbps, 36 Mbps, 48 Mbps, and 54 Mbps. AR5211-based devices support 802.11a and 802.11b
operation with transmit speeds as above for 802.11a operation and 1Mbps, 2Mbps, 5.5 Mbps and 11Mbps for
802.11b operation. AR5212-based devices support 802.11a, 802.11b, and 802.11g operation with transmit
speeds appropriate to each. AR5416-class devices are capable of 802.11n operation but are supported only
in legacy modes (802.11a, 11b, 11g). Most chips also support an Atheros Turbo Mode (TM) that operates in
the 5Ghz frequency range with 2x the transmit speeds. Some chips also support Turbo mode in the 2.4Ghz
range with 802.11g though this support is not presently available due to regulatory requirements. (Note that
Turbo modes are, however, only interoperable with other Atheros-based devices.) AR5212-based devices
also support half- (10MHz) and quarter-width (5MHz) channel