BSD Kernel Interfaces Manual
ale — Atheros AR8121/AR8113/AR8114 Gigabit/Fast Ethernet driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The ale device driver provides support for Atheros AR8121 PCI Express Gigabit Ethernet controllers and
Atheros AR8113/AR8114 PCI Express Fast Ethernet controllers.
All LOMs supported by the ale driver hav e TCP/UDP/IP checksum offload for both receive and transmit,
TCP segmentation offload (TSO), hardware VLAN tag stripping/insertion features, Wake On Lan (WOL)
and an interrupt coalescing/moderation mechanism as well as a 64-bit multicast hash filter.
The AR8121 also supports Jumbo Frames (up to 8132 bytes), which can be configured via the interface
MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the
adapter to receive and transmit Jumbo Frames.
The ale driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user can manually override the
autoselected mode by adding media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation.
Set 100Mbps (Fast Ethernet) operation.
1000baseTX Set 1000baseTX operation over twisted pair.
The ale driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The ale device driver provides support for the following Ethernet controllers:
• Atheros AR8113 PCI Express Fast Ethernet controller
• Atheros AR8114 PCI Express Fast Ethernet controller
• Atheros AR8121 PCI Express Gigabit Ethernet controller
Tunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
This tunable disables MSI support